Why do I frequently need to re-enable Flash?

Adobe is planning to stop updating and distributing Flash Player at the end of 2020. Because of this, several browsers are changing the way Flash is enabled. Chrome version 69+ and Edge 18+ no longer allows you to set permanent Flash permissions for sites that use Flash (including Lumosity!) By default, Chrome and Edge sets Flash to always ask you to enable. 

Currently, most of our games require Flash in order to play, but the good news is that we're working on transitioning the majority of our games over to HTML5. In fact, our newer games already use HTML5. Transitioning to HTML5 brings this Flash problem to a permanent end. In the interim, you can continue playing the games you love by simply allowing flash to run when prompted.

Learn more about the move off Flash and the format of our new HTML5 games.

Last Updated:
Was this article helpful?